View discussion in a popup

Replying to:

Re: iPhone drops calls when using wifi calling


If you're in an area that has both a Wi-Fi network and a weak cellular signal, sometimes your Wi-Fi calls will fail. Looks like it's a result of the phone trying to connect to the cellular network instead of sticking with Wi-Fi.

A solution that has worked for me is to disable the cellular option. I hadn't seen how to turn off cellular calling, finally stumbled on the answer. It's a bit clunky but has worked out pretty well so far. Using the iPhone Control Center (accessed by swiping up from the bottom of screen OR Settings > Control Center):

Turn on Airplane Mode. Cellular and Wi-Fi will both be turned off. Turn Wi-Fi back on. Cellular is now Off, Wi-Fi (including Wi-fi calling) is on.