I agree, and would also like to be able to hide the "Safety 24/7 threat protection is ON" notification, it's just more unnecessary clutter. 
My wife's S8+ has the same issue, I can be sitting right beside her with my old Galaxy S5, connected and using the interwebs while she's got nothing. Really disappointing. I was waiting to upgrad... See more...
My wife's S8+ has the same issue, I can be sitting right beside her with my old Galaxy S5, connected and using the interwebs while she's got nothing. Really disappointing. I was waiting to upgrade to an S8+ too on a Black Friday deal, but not now!
I also noticed significantly increased battery drain after the update. I switched my Network to CDMA/LTE also, but I think the real killer was a couple of other settings that the update (re)enabl... See more...
I also noticed significantly increased battery drain after the update. I switched my Network to CDMA/LTE also, but I think the real killer was a couple of other settings that the update (re)enabled that I had turned off; the SmartStay option in the Display settings, and the option in S-Voice settings where it continuously monitors the microphone, waiting for you to say the 'magic wake-up command', that one even says it will drain your battery! With all that stuff on, my battery usage list would show "Screen" as the top item, and that was with the phone sitting untouched in sleep mode for several hours! I also found a couple of the "location update" related settings turned on that I was pretty sure I had disabled. I'm not sure which of those made the most difference (I suspect it was the S-Voice thing), but after putting all that back to way I had it, my battery usage is back to normal. Many people in the DroidForums discussions are saying they had to do a FDR to fix this, but I suspect all that is really accomplishing is turning off all those battery-eating settings that the update (re)enabled. If anyone is still having issues after switching off the Global radio setting, I'd try the stuff I mentioned first, and if you still see battery drain with your settings back to pre-update values, maybe try the factory data reset.
BigErnM wrote: This has to be a Verizon network issue and not an iPhone 5 issue.  The wrong date and time bug is happening on my iPhone 5 and my wife's Galaxy S3 for the past 3 or 4 days.... See more...
BigErnM wrote: This has to be a Verizon network issue and not an iPhone 5 issue.  The wrong date and time bug is happening on my iPhone 5 and my wife's Galaxy S3 for the past 3 or 4 days.  We are just on the edge of 4G LTE coverage.  It always happens when we are at home and happens when I am on wireless with cellular data turned off and when I have both wireless and cellular data turned off. I don't know if that has anything to do with it or not.  On my iPhone 5 toggling airplane mode on and off fixes the issues.  On my wife's GSIII it seems to spontaneously correct. Agreed, this is happening on both of our Galaxy S3's. We've had the phones for a couple months, the problem started about 2 weeks ago. It also seems to happen to us mostly at home, and in other spotty coverage areas, never at work. I'm tired of my calendar events and alarms going off randomly in the middle of the night because of this, so I've turned off 'automatic time updates from the network' until Verizon fixes the problem.