Charging issues - please help!!!!

Miembro

My family's Ellipsis 7 tablet, as most 7's and 8's apparently do, has been having some serious charger issues and now will not power on or show any signs of life whatsoever. We got it for free a little under a year ago when buying another device at Verizon, and it replaced the first Ellipsis 7 tablet we had, which met the same untimely fate. For a while now, it has been losing battery life very quickly and dying while plugged in / charging if it is at or below 4%; it would also glitch out really badly when we plugged it in so that if you even so much as tapped the screen lightly it would do things like opening another unrelated app, pulling up some dialogue menu from Settings, etc. Two days ago it died and was plugged in overnight, but it had only reached 4% after having been on the charger for almost 12 hours. We left it plugged in all day yesterday and it only made it up to about 9% before dying again on the charger.

We then looked up some more information on this issue and decided to try the two key combinations claimed by other Ellipsis 7 users to revive their tablets after experiencing similar issues: holding the power button down for 20 seconds and then pressing it again for 3 seconds (which didn't work), and then holding down the power button and the down volume key to bring up a blue and yellow Chinese menu, scrolling down to the bottom of the menu with the down volume key, and then holding both volume keys down to select it. This method didn't appear to work last night (it only caused the screen to go black), but in the morning when we attempted to see if the tablet was still working, it had reached 46%. However, we knew from prior experience with our first Ellipsis that the tablet would most likely die immediately if it was unplugged, so we decided to leave it on the charger until it reached 100% and then see what happened. Later in the morning it was again accidentally knocked it off of the charger, causing it to die (all of the micro USB cords we have are incredibly fragile and have to be positioned precisely if we want to charge any of our devices). We tried the power button and down volume key combination again and then selected the bottom option on the Chinese menu once more, which shut down the tablet. Then we held down the power button until it booted up again, displaying the lock screen, which stated that the tablet had a charge of ZERO percent. And then, unsurprisingly, it shut down again.

For some background, so that representatives of Verizon don't have to ask and we can get to the bottom of this quickly:

  • No, the tablet has not had any water damage.
  • Yes, the tablet has been dropped before, but there were no signs of damage when this occurred. Could this contribute to the problem?
  • No, we have not been using the original charger that came with the tablet. We were under the impression that micro USB cords and their charging blocks were interchangeable, but apparently it is always optimal to use the proper charger. We will try to keep this in mind with our Ellipsis 8 tablet, which we received (again, for free) about two weeks ago.
  • Yes, we have tried plugging it into a PC and into the wall and the results were the same: nothing. (Is charging affected by using an extension cord vs plugging directly into the wall?)
  • No, we have not done a factory data reset. If someone could tell me how to do this I would greatly appreciate it.
  • We have the SIM card out of the tablet because we realized it preserved battery more without it. If we need to put it back in, please let me know.

We are not able to send the tablet off for the $85 repair, so I would greatly appreciate it if anyone could give me advice as to how to fix this problem! Right now I'm thoroughly convinced that there isn't any hope. In the words of another user who I saw posted on the Verizon forums with this same issue: "I got this tablet for free. Now I know why."

Labels (1)
Etiquetas (3)
0 Me gusta