Re: MIFI 8800l JetPack Suddenly Drops Connection


Aloha, I just wanted to chime in and add my name as someone who is also experiencing the Jetpack 8800l dropped internet issue (not to be confused with a dropped cellular connection which is NOT the problem) that everyone else on this blog has been discussing.  My troubles seem to have begun about five days ago although, as a fulltime RV'er parked in desolate AZ desert prior to five days ago, I don't really know when the issue arose.  It had worked well enough prior to that.

I just spent the better part of an hour with a level 2 technical support rep and he has begun a trouble ticket that will advance to back of the house technicians after 24hrs of device "observation."  Important to note that the tech recognized the multiple 921.6MB data flow cutoffs in my data usage file.

Also, I tried to exchange my Jetpack at a corporate Verizon store in Yuma, AZ today and was told I would have to give up the device to them while I waited for the replacement to arrive in at their store (I have no local delivery address).  I protested their "policy" to take possession of the original device (which of course prevents me from having any internet at all) before they could order it's replacement (nevermind simply exchanging it with one they have in stock) as ludacris and they simply shrugged and sent me on my way.

If it weren't for the fact that I can't find any other provider with unlimited data at $70 per month, I'd drop these bozos in a heartbeat.